Banco do Brasil delay to process payments
Incident Report for Transfeera
Resolved
No more delays at the moment.
Posted Jan 19, 2021 - 15:46 GMT-03:00
Identified
Banco do Brasil is having a delay in processing payments.
Posted Jan 19, 2021 - 09:36 GMT-03:00