Banco do Brasil delay to process payments
Incident Report for Transfeera
Resolved
No more delays at the moment.
Posted Jan 22, 2021 - 13:45 GMT-03:00
Identified
Banco do Brasil is having a delay in processing payments.
Posted Jan 22, 2021 - 11:37 GMT-03:00