Instabilidade na infraestrutura do sistema
Incident Report for Transfeera
Postmortem

Estamos cientes de que na última quarta-feira, 09/03/2022, um incidente em nosso provedor de infraestrutura (AWS), no sistema de mensageria que utilizamos (SQS) em nossos serviços, desencadeou uma série de eventos que ocasionaram indisponibilidade em nossos serviços de Pagamentos e Validações de dados bancários por micro depósito.

Confira a linha do tempo de eventos:

17:40 - Início dos erros do SQS nos nossos serviços;

17:57 - Paramos de receber notificações de liquidação dos Qr Codes de cobrança Pix do nosso banco parceiro direto;

18:45 - Resolvido incidente do SQS junto ao provedor de infraestrutura AWS;

Durante essa janela estávamos recuperando as notificações de liquidação de Qr Codes que não havíamos recebido durante a indisponibilidade do SQS e investigando o motivo de não estar chegando novos pagamentos.

22:20 - Identificado que nosso banco parceiro havia desligado o envio de notificações de liquidação Pix;

22:25 - Reabilitado envio de notificações e reenvio das notificações pendentes no banco parceiro;

22:30 - Banco de dados do nosso serviço de extrato não suportou o aumento de carga, ficando irresponsivo e fez com que Pagamentos e Validações de dados bancários por meio de micro depósito ficassem indisponíveis.

Durante essa janela de tempo nosso time estava focado em recuperar os ambientes após a sobrecarga no serviço.

00:47 - Banco de dados do serviço de extrato foi normalizado;

00:58 - Finalizado o processamento de todos os Pix pendentes.

Reiteramos nosso compromisso com a qualidade do serviço que oferecemos. Nos preocupamos com nossos clientes, por isso, pedimos sinceras desculpas pelo ocorrido e informamos também que nossas equipes estão totalmente empenhadas e comprometidas em uma série de tarefas para que tal acontecimento não volte a ocorrer.

Agradecemos a compreensão, e em caso de dúvidas, entre em contato pelo nosso suporte.

Posted Mar 11, 2022 - 10:02 GMT-03:00

Resolved
Esse incidente foi resolvido.
Posted Mar 10, 2022 - 01:23 GMT-03:00
Monitoring
O problema foi resolvido, estamos monitorando o ambiente para garantir que não ocorra mais nenhuma instabilidade.
Posted Mar 09, 2022 - 18:51 GMT-03:00
Identified
Identificamos uma instabilidade na infraestrutura do nosso provedor de infraestrutura (AWS). Estamos trabalhando para solucionar o problema o mais rápido possível.
Posted Mar 09, 2022 - 18:32 GMT-03:00
This incident affected: Pagamentos (Pix Cash Out, Pix Cash In) and Transfeera API, ContaCerta API, Webhooks.