CAIXA delay to process payments
Incident Report for Transfeera
Resolved
No more delays at the moment.
Posted Oct 23, 2020 - 13:45 GMT-03:00
Identified
CAIXA is having a delay in processing payments.
Posted Oct 23, 2020 - 09:10 GMT-03:00