CAIXA delay to process payments
Incident Report for Transfeera
Resolved
This incident has been resolved.
Posted Aug 06, 2020 - 18:34 GMT-03:00
Identified
CAIXA is having a delay in processing payments.
Posted Aug 06, 2020 - 12:09 GMT-03:00